tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Display a static page while application loading.
Date Tue, 20 Sep 2011 13:49:46 GMT
2011/9/19 Eric Bouer <ericbouer@gmail.com>:
>
> Hello list.
> I'm using tomcat for a J2EE application that uses Spring/Hibernate/JSF.
> The spring container and hibernate bootstrap are slow and the users get a
> blank page or no response from tomcat while the application starts.
> In order to avoid that I was thinking about some static page that can be
> served by a different thread but the problem is that there are muiltiple
> wars and I wish to have a simple solution.
>
> I'd like to know if Tomcat already provides a solution for this problem or
> if it is a planned feature request (couldn't find any)
> Or is there another way to solve this issue?

1. There are many versions of Tomcat. What one you are using / targeting?

2. Does your Spring initialization happens when the web applications
starts up, or when it is accessed for the first time? It depends on
your you configure spring contexts in your webapp.

3. Are you concerned with blank response while Tomcat itself starts
up,  or when you redeploy your application while Tomcat is already
running?

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message