tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tomcat Redirect Issue - Extra "/" after hostname - Help Please
Date Wed, 14 Sep 2011 20:39:32 GMT
2011/9/14 Shanti Suresh <shanti@umich.edu>:
> All,
>
> We are running into a peculiar issue.   We have Tomcat 6.0.24 front-ended by
> Apache2.2.3.  We have a VirtuslHost serving port 80 where Apache simply
> hands off "/" to Tomcat's load-balancer.
>
> <VirtualHost *:80>
>  ServerName wwwprod.lsa.umich.edu
>  ServerAlias wwwprod www www.lsa.umich.edu
>  Redirect         / balancer://dsmdelivery/
>  ProxyPass        / balancer://dsmdelivery/
>  ProxyPassReverse / balancer://dsmdelivery/
>  TraceEnable Off
> </VirtualHost>


The examples in [1] do not have trailing "/" neither in <Proxy>
element nor in ProxyPass setting, while [2] has one such example
(search for "A sample balancer setup").

[1] http://httpd.apache.org/docs/2.1/mod/mod_proxy_balancer.html
[2] http://httpd.apache.org/docs/2.1/mod/mod_proxy.html#proxypass

So, how is your <Proxy> element configured?


> The problem cropped up when all systems including the F5 load-balancer
> had to be rebooted after last weekend's storm.

So it did work before?


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message