tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Re: catalina_pid file contains +1 pid number instead of correct pid
Date Thu, 29 Sep 2011 06:22:20 GMT
On 29/09/2011 06:30, Raghu GS wrote:
> 
> 
> 
> Konstantin Kolinko wrote:
>>
>> 2011/9/27 Raghu GS <raghu.gs@i10n.com>:
>>>
>>> Hello Everybody
>>>
>>> We are using Tomcat 6.20 in CentOS 5.3 server.
>>
>> 6.0.20 ??
>>
>> You should read
>> http://tomcat.apache.org/security-6.html
>>
>> as well as all the fixed issues in changelog.
>>
>>> I have recently enabled catalina_pid functionality using environment
>>> variable.
>>> The PID file got created and contains +1 PID number.
>>>
>>> If the Tomcat's real PID number 5446, the pid file would contain 5447 as
>>> PID
>>> number.
>>
>> catalina.sh is a shell script file. There are not many secrets there
>> and it is editable.
>> You should try to debug what really goes on on your system.
>>
>> IIRC there were some talks about using "exec" command vs "eval"
>> command  in the script to launch the process.
>>
>> Anyway, if CATALINA_PID file were not working I think somebody would
>> report it, but 6.0.20 was so old ago and I do not remember such
>> reports.
>>
>>> Please help me to resolve this problem as we are using tomcat in 10 of
>>> our
>>> servers.
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> Actually the PID number in the PID file is not wildly incorrect.
> So, please suggest me an easy to implement solution.

Upgrade to the latest 6.0.33 and try again?


p




Mime
View raw message