tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: tomcat 7.0.21: bug in RemoteAddrValve?
Date Wed, 14 Sep 2011 15:28:04 GMT
Francis GALIEGUE wrote:
> Hello,
> 
> I have a base Tomcat install with only the manager webapp in it at
> startup (I deploy other webapps using it in text mode) but since I
> upgraded from 7.0.16 to 7.0.21, the manager no longer works with the
> RemoteAddrValve.
> 
> The context.xml is:
> 
> ----
> <Context docBase="/usr/share/tomcat7/webapps/manager"
>     antiResourceLocking="false" privileged="true">
>     <Valve className="org.apache.catalina.valves.RemoteAddrValve"
>         allow="127\.0\.0\.1|::1"/>
> </Context>
> ----
> 
> This worked fine with 7.0.16 and doesn't work anymore with 7.0.21, I
> get 403 each time... Anyone seeing the same problem?
> 
Maybe try to modify that regexp somewhat, like to
allow="(127\.0\.0\.1)|(::1)"
or
allow="127\.0\.0\.1|\:\:1"
just in case the regexp library version changed, and it now interprets the original 
expression slightly differently ?
Could it also be that previously, Tomcat saw an IPv4 address and it worked, but now it 
sees an IPv6 address and the "::1" part in fact never worked, but was never used before ?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message