tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Re : Re : Performance issue in simpleTags and tagfiles
Date Wed, 07 Sep 2011 20:20:42 GMT
On 07/09/2011 20:36, Adrian Gonzalez wrote:
> Sorry, no real difference.
> 
> Even worse, I'm on my home computer and here I don't see anymore the *5 difference between
simple tags and classic tags.

The figures I saw were:
Test    OP      Me      Cached
tagfile 500     328     203
classic 100     141     156
simple  500     250     156
none    94      140     156

A slight increase in the case where the cache isn't used and a
reasonable improvement in the other cases.

Performance tuning is always going to be system dependent. In this case
I think there us enough evidence to justify putting in the cache - even
if this is effectively a micro benchmark.

> I'll continue these tests tomorrow at work (perhaps there's some file scanning / reading
in action - and since I'm with AV software...).

I'd be very interested to see those results.

>  - Tests results - 
> 
> Downloaded tomcat trunk sources from http://svn.apache.org/repos/asf/tomcat/trunk/

That is actually 8.0.x but there is currently very little difference
between that an 7.0.x with is at:
http://svn.apache.org/repos/asf/tomcat/tc7.0.x/trunk/

Cheers,

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message