tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nubile <ryan.ken...@gmail.com>
Subject Re: Problems with ImageIO
Date Thu, 29 Sep 2011 23:05:31 GMT

I saw this problem while loading a TGA reader. I was able to first resolve
the problem by disabling JreMemoryLeakPreventionListener, but a better
solution seems to be to put a static initializer in my webapp code that
forces the container to re-scan for reader implementations once the webapp
classloader is up. For example:

	static {
		ImageIO.scanForPlugins();
	}


, and was able to resolve it by calling 

Thad Humphries-2 wrote:
> 
> I believe I'm seeing the same problem that Simone (msg #210515) is having
> (this after running Tomcat for YEARS without a hitch).
> 
> I use JAI and JAI-IMAGE I/O in various servlets.  I'm running Java 1.5.17
> without the JAI or JAI-IMAGE I/O installed.  I've put jai_codec.jar,
> jai_core.jar, and jai_imageio.jar in my application's WEB-INF/lib
> directory.
> 
> My application runs without a hitch on Tomcat 6.0.14 on a Linux server
> (and
> has run fine for over a year).  I have also run it on a Macintosh with
> Tomcat 6.0.20.
> 
> Today I installed Tomcat 6.0.26 on Linux and tried running my webapp. 
> Under
> this version of Tomcat, Iterator<ImageReader> returned by
> ImageIO.getImageReadersByFormatName("tiff") returns false for hasNext().
> What gives?
> 
> Are you seeing this, Simone?
> 
> -- 
> "Hell hath no limits, nor is circumscrib'd In one self-place; but where we
> are is hell, And where hell is, there must we ever be" --Christopher
> Marlowe, 'Doctor Faustus' (v, 121-24)
> 
> 

-- 
View this message in context: http://old.nabble.com/Problems-with-ImageIO-tp28169228p32553281.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message