tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From throwsCode <donmillho...@yahoo.com>
Subject Re: CGIServlet - php
Date Sat, 03 Sep 2011 00:36:26 GMT

Hi all:

An update I entered the following directly into my browser:
          http://localhost:8080/secondDynamicWeb/cgi-bin/echoInfo.php

And got the a 404 Error - Servlet CGI not available.

>From this it appears that the servlet is not available but has been defined
because the URL pattern /cgi-bin/ appears to call the Servlet as defined in
the web.xml

Which I have set as follows:

    <servlet>
        <servlet-name>cgi</servlet-name>
       
<servlet-class>org.apache.catalina.servlets.CGIServlet</servlet-class>
        <init-param>
          <param-name>debug</param-name>
          <param-value>6</param-value>
        </init-param>
        <init-param>
          <param-name>cgiPathPrefix</param-name>
          <param-value>WEB-INF/cgi</param-value>
        </init-param>
        <init-param>
          <param-name>executable</param-name>
          <param-value></param-value>
        </init-param>
         <load-on-startup>5</load-on-startup>
    </servlet>
 
AND 

    <servlet-mapping>
        <servlet-name>cgi</servlet-name>
        <url-pattern>/cgi-bin/*</url-pattern>
    </servlet-mapping>

I would appreciate any advice you might offer.

TC





-- 
View this message in context: http://old.nabble.com/CGIServlet---php-tp32390310p32390388.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message