tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Garcia <bobg.li...@gmail.com>
Subject tomcat 7.0.20 nio problem
Date Sat, 27 Aug 2011 21:15:54 GMT
Apologies if this is a known issue or a simple config error on my part. I
have not been able to find anything similar in my searches.

I am using tomcat-7.0.20 configured with
protocol=org.apache.coyote.http11.Http11NioProtocol, and using OpenJDK
1.6.0_22 on Fedora 15.

I have a webapp at webapps/demo and a servlet mapped to demo/foo.  Tomcat is
also serving some static content from the demo directory, including image
files in demo/imgs.  I have instrumented by event method to report values
associated with BEGIN events.

The problem (as I see it) is that my servlet is occasionally, non
deterministically, receiving requests for static that should (I think) be
handled directly by Tomcat. For example:

http://192.168.0.2:8080/demo/imgs/example_200.jpg

as reported by event.getHttpServletRequest().getRequestURL()

Based on my understanding, my servlet should never receive such a request
since it fails to conform to my servlet-mapping as shown below:

<servlet-mapping>
   <servlet-name>demo</servlet-name>
   <url-pattern>/foo</url-pattern>
</servlet-mapping>

Another, perhaps related, problem is that I am seeing, again
non-deterministically, is that event.getHttpServletResponse().isCommitted()
is occasionally returning true when I initially receive the BEGIN message.
Specifically, this always seems to be the case when I receive non-servlet
URLs such as the one above (though it is also occasionally true for servlet
related URLS as well).

Any help/pointers is much appreciated.

-bg

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message