tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject Re: 503 error - service not available
Date Thu, 04 Aug 2011 02:38:40 GMT
Obviously apache can't connect to tomcat. Any firewall/load balancer changes
maybe done last night between apache and tomcat? Can you access tomcat apps
bypassing apache? Can you telnet to tomcat server on the tomcat port from
the apache? Any errors in the tomcat log? Have you tried restarting tomcat?


Igor

On Thu, Aug 4, 2011 at 12:28 PM, Dave Filchak <submit@zuka.net> wrote:

>
> Not sure what happened here. The app was working just fine until today. I
> am getting a 503 Service temporarily unavailable error when trying to
> connect to a tomcat site using Apache as the front end and mod_jk
> connectors. I have verified that tomcat is running on the correct ports
> using:netstat -atp | grep java. I see no errors in the message logs ( we are
> on CentOS by the way ) but I do see:
>
> |[Wed Aug 03 18:49:24 2011] [15605:1199618400] [info]
> ajp_service::jk_ajp_common.c (2540): (exodus) sending request to tomcat
> failed (recoverable), because of error during request sending (attempt=2)
> [Wed Aug 03 18:49:24 2011] [15605:1199618400] [error]
> ajp_service::jk_ajp_common.c (2559): (exodus) connecting to tomcat failed.
> [Wed Aug 03 18:49:24 2011] exodus www.exodusdecoded.com 0.198512
> [Wed Aug 03 18:49:24 2011] [15605:1199618400] [info] jk_handler::mod_jk.c
> (2618): Service error=-3 for worker=exodus
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [info]
> jk_open_socket::jk_connect.c (622): connect to 174.122.30.18:8010 failed
> (errno=111)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [info]
> ajp_connect_to_endpoint::jk_**ajp_common.c (959): Failed opening socket to
> (174.122.30.18:8010) (errno=111)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [error]
> ajp_send_request::jk_ajp_**common.c (1585): (exodus) connecting to backend
> failed. Tomcat is probably not started or is listening on the wrong port
> (errno=111)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [info]
> ajp_service::jk_ajp_common.c (2540): (exodus) sending request to tomcat
> failed (recoverable), because of error during request sending (attempt=1)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [info]
> jk_open_socket::jk_connect.c (622): connect to 174.122.30.18:8010 failed
> (errno=111)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [info]
> ajp_connect_to_endpoint::jk_**ajp_common.c (959): Failed opening socket to
> (174.122.30.18:8010) (errno=111)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [error]
> ajp_send_request::jk_ajp_**common.c (1585): (exodus) connecting to backend
> failed. Tomcat is probably not started or is listening on the wrong port
> (errno=111)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [info]
> ajp_service::jk_ajp_common.c (2540): (exodus) sending request to tomcat
> failed (recoverable), because of error during request sending (attempt=2)
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [error]
> ajp_service::jk_ajp_common.c (2559): (exodus) connecting to tomcat failed.
> [Wed Aug 03 18:50:46 2011] exodus www.exodusdecoded.com 0.197989
> [Wed Aug 03 18:50:46 2011] [15851:1189128544] [info] jk_handler::mod_jk.c
> (2618): Service error=-3 for worker=exodus
>
> |
>
> in the mod_jk.log file. Apache is running. I am stumped but really need to
> get this back running if anyone out there is more experienced at tomcat and
> apache connectors than I am, which wouldn't take much ;-)
>
> Cheers,
>
> Dave
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message