tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Casper Wandahl Schmidt <kalle.pri...@gmail.com>
Subject Re: Cannot build mod_jk.1.2.32
Date Mon, 29 Aug 2011 09:46:59 GMT


Den 29-08-2011 11:30, Mladen Turk skrev:
> On 08/29/2011 10:55 AM, Casper Wandahl Schmidt wrote:
>> So I fanilly had time to check up on this topic :)
>>
>> Lets start with the apache2ctl -V command:
>> Server version: Apache/2.2.8 (Ubuntu)
>>
>> I suppose the Server MPM: Prefork (you have Worker) might be the 
>> reason why I couldn't get the mod_jk working earlier because apache 
>> is not set up for using a worker as I was trying to?
>>
>
> Nope.
Nice, then I should be able to make it work soon :)
>
>> Next the other apache info:
>> ii apache2 2.2.8-1ubuntu0.19
>> ii apache2-mpm-prefork 2.2.8-1ubuntu0.19
>> ii apache2-src 2.2.8-1ubuntu0.19
>> ii apache2-threaded-dev 2.2.8-1ubuntu0.19
>> ii apache2-utils 2.2.8-1ubuntu0.19
>> ii apache2.2-common 2.2.8-1ubuntu0.19
>> ii libapache2-mod-php5 5.2.4-2ubuntu5.17
>>
>> Finally the beginning of the error-log I made when running make:
>
> You don't need source packages.
> All you need are -dev packages.
> Then configure --with-apxs=/path/to/the/apxs(2)
As I think I said in the beginning ./configure complained about no 
apache and giving me an error about some source directory (can't 
remember the details)
>
>> In file included from mod_jk.c:29:
>> /usr/src/apache2/include/ap_config.h:25:17: error: apr.h: No such 
>> file or directory
>> In file included from /usr/src/apache2/include/ap_config.h:26,
>
> This happens since you forced the 'src' directory.
> Sources like name suggests contain sources, apr.h and apu.h are generated
> when you build the apr/apr-util (can be part of httpd build process)
> but you don't need to build the httpd. Your dist already have it.
>
>>>
>>> $ svn checkout 
>>> https://svn.apache.org/repos/asf/tomcat/jk/tags/JK_1_2_32
>>> $ cd JK_1_2_32/native
>>> $ ./buildconf.sh (you don't need to do this if you didn't use svn)
>>> $ which apxs2
>>> /usr/bin/apxs2
>>> $ ./configure --with-apxs=/usr/bin/apxs2
>>>
>
> Note: Some distros don't have 2 sufix. It's just /xxx/yyy/apxs
> However seems Ubuntu has /usr/bin/apxs2
I tried removing my working directory and unpacking the tar.gz again. 
This time I did a chown before trying ./configure --with-apxs (leaving 
the 2 out)=/usr/bin/apxs2 - it still gave the "no apache given" 
"warning" but it actually did configure thinks correctly this time :) I 
don't know if it was because of the chown (ran ./configure as root 
before because the folder was owned by root:bin after unpacking with 
sudo tar ....) or because I changed --with-apxs2 to --with-apxs 
(although I believe I tried both before starting this thread because I 
only found the --with-apxs2 switch after searching google for days)

Anyway I was able to run make successfully and now I have the mod_jk.so :)

Thank you all for your time and help. I might be back with questions on 
how to make the connector work at a later time :)
>
>
>
>
> Regards

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message