tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Elliot <...@lidalia.org.uk>
Subject Re: Wrong Response returned for a Request
Date Sat, 30 Jul 2011 07:37:46 GMT

On 28 Jul 2011, at 10:16, Mark Thomas wrote:

> On 28/07/2011 07:34, Robert Elliot wrote:
>> 
>> 
>> 
>> 
>> On 28 Jul 2011, at 00:24, David Rees <drees76@gmail.com> wrote:
>>> 
>>> But perhaps this issue applies:
>>> https://issues.apache.org/bugzilla/show_bug.cgi?id=50189
>>> 
>>> -Dave
>>> 
>> Thanks very much for the pointer - however, we're using mod_proxy rather than mod_jk
so presumably this wouldn't apply?
> 
> mod_proxy_ajp or mod_proxy_http?
> 
> If mod_proxy_ajp, then it is possible that this issue might occur (I
> haven't checked the source code or tested it to be sure).
> 
> Mark

Mod_proxy_http.  We enabled the access valve with a log pattern that included the number of
bytes in the response in order to be able to match requests to responses at the Tomcat level
and saw that the correct responses were being returned there but incorrect ones then returned
by HTTPD/mod_proxy.  As we were using an old version of HTTPD we've upgraded it (from 2.2.3
to 2.2.19), and thus far we've been unable to reproduce the problem again.  Thanks for the
help.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message