tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Multiple errors (regressions) on Tomcat 7.0.17
Date Tue, 05 Jul 2011 09:20:56 GMT
2011/7/4 Mark Thomas <markt@apache.org>:
> On 04/07/2011 16:56, Mark Thomas wrote:
>> On 03/07/2011 15:14, eurotrans-Verlag wrote:
>>>>> 2) When using the ISAPI Redirector 1.2.32 and Tomcat Native 1.1.20
>>>> which is
>>>>> included in the windows distribution, I get these errors when a
>>>> client makes
>>>>> a request to IIS which is redirected to Tomcat, resulting in 100% CPU
>>>> usage
>>>>> by tomcat's process:
>>>>
>(...)
>
> The problem has been found and fixed. I'm leaning towards stopping the
> 7.0.17 release and re-starting with a 7.0.18 tag.
>

I do not quite get the fix.

The fix:
http://svn.apache.org/viewvc?rev=1142748&view=rev

Apparently the issue was introduced by this commit:
http://svn.apache.org/viewvc?rev=1135208&view=rev

r1142748 does not revert r1135208 and  it either removes a valid piece
of code or a problem was introduced earlier. The removed code
originates from r1003177 (9 months ago),

http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/coyote/ajp/AjpAprProcessor.java?diff_format=l&r1=1003176&r2=1003177


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message