tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Multiple errors (regressions) on Tomcat 7.0.17
Date Tue, 05 Jul 2011 09:33:54 GMT
On 05/07/2011 10:20, Konstantin Kolinko wrote:
> 2011/7/4 Mark Thomas <markt@apache.org>:
>> On 04/07/2011 16:56, Mark Thomas wrote:
>>> On 03/07/2011 15:14, eurotrans-Verlag wrote:
>>>>>> 2) When using the ISAPI Redirector 1.2.32 and Tomcat Native 1.1.20
>>>>> which is
>>>>>> included in the windows distribution, I get these errors when a
>>>>> client makes
>>>>>> a request to IIS which is redirected to Tomcat, resulting in 100%
CPU
>>>>> usage
>>>>>> by tomcat's process:
>>>>>
>> (...)
>>
>> The problem has been found and fixed. I'm leaning towards stopping the
>> 7.0.17 release and re-starting with a 7.0.18 tag.
>>
> 
> I do not quite get the fix.
> 
> The fix:
> http://svn.apache.org/viewvc?rev=1142748&view=rev
> 
> Apparently the issue was introduced by this commit:
> http://svn.apache.org/viewvc?rev=1135208&view=rev

Not it wasn't. r1135208 is fine. The problem was this commit:
http://svn.apache.org/viewvc?rev=1137184&view=rev

That moved the call to Poller.add() to one consistent place for all
connectors but failed to remove the Poller.add() in the AJP Processor.

> r1142748 does not revert r1135208

Correct. As intended.

> and  it either removes a valid piece
> of code or a problem was introduced earlier.

Neither of those statements is correct. r1142748 removes the duplicate
call to the Poller that should have been removed in r1137184. Why Linux
copes with this and Windows crashes I have no idea but r1142748 is the
right fix for this regression.

Mark



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message