tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Multiple errors (regressions) on Tomcat 7.0.17
Date Mon, 04 Jul 2011 15:56:28 GMT
On 03/07/2011 15:14, eurotrans-Verlag wrote:
>>> 2) When using the ISAPI Redirector 1.2.32 and Tomcat Native 1.1.20
>> which is
>>> included in the windows distribution, I get these errors when a
>> client makes
>>> a request to IIS which is redirected to Tomcat, resulting in 100% CPU
>> usage
>>> by tomcat's process:
>>
>> Under what circumstances? Some requests, all requests? The APR/native
>> AJP connector works with mod_jk and mod_proxy_ajp on linux so it looks
>> like either the ISAPI redirector is sending something unexpected that
>> isn't handled well or the windows specific code in the APR/native
>> connector isn't handling something.
> 
> For this test, I downloaded the Tomcat 7.0.17 (windows 64 bit) and extracted
> it to a directory. I didn't changed anything in the Tomcat directory (also
> not the config files). I set the ISAPI Redirector 1.2.32 to redirect all
> requests to Tomcat on port 8009, using ajp13.

OK. I've set up IIS 7 and Tomcat 7.0.17 and I see the same thing.

There has been some refactoring of the connector code but (famous last
words) it should have been harmless. I'm looking at this now...

Mark



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message