tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Multiple errors (regressions) on Tomcat 7.0.17
Date Sun, 03 Jul 2011 13:38:47 GMT
On 03/07/2011 13:54, eurotrans-Verlag wrote:
> Hi all,
> 
> today I downloaded the not yet released Tomcat 7.0.17 (downloaded it from
> http://people.apache.org/~markt/dev/tomcat-7/v7.0.17/bin/ ) to test it on a
> Windows Server 2008 R2 (64 bit) system with Sun Java 1.6.0_26 (64 bit),
> using IIS 7.5 and the ISAPI Redirector 1.2.32 (from
> http://people.apache.org/~mturk/tomcat-connectors/jk/binaries/windows/ ). I
> used the 64 bit versions of Tomcat and the ISAPI redirector.
> 
> I noticed some regressions which do not occur when using Tomcat 7.0.16
> instead.
> 
> 
> 1) When declaring the CrawlerSessionManagerValve at Engine level in
> server.xml:
> 
> <Valve className="org.apache.catalina.valves.CrawlerSessionManagerValve"/>
> 
> then I get a NPE when a client makes a request to Tomcat (or to IIS, which
> is redirected to Tomcat by the ISAPI redirector):

If you explicitly set crawlerUserAgents, that will be resolved.

> 2) When using the ISAPI Redirector 1.2.32 and Tomcat Native 1.1.20 which is
> included in the windows distribution, I get these errors when a client makes
> a request to IIS which is redirected to Tomcat, resulting in 100% CPU usage
> by tomcat's process:

Under what circumstances? Some requests, all requests? The APR/native
AJP connector works with mod_jk and mod_proxy_ajp on linux so it looks
like either the ISAPI redirector is sending something unexpected that
isn't handled well or the windows specific code in the APR/native
connector isn't handling something.

Mark



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message