tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "eurotrans-Verlag" <verlag.preis...@t-online.de>
Subject Multiple errors (regressions) on Tomcat 7.0.17
Date Sun, 03 Jul 2011 12:54:35 GMT
Hi all,

today I downloaded the not yet released Tomcat 7.0.17 (downloaded it from
http://people.apache.org/~markt/dev/tomcat-7/v7.0.17/bin/ ) to test it on a
Windows Server 2008 R2 (64 bit) system with Sun Java 1.6.0_26 (64 bit),
using IIS 7.5 and the ISAPI Redirector 1.2.32 (from
http://people.apache.org/~mturk/tomcat-connectors/jk/binaries/windows/ ). I
used the 64 bit versions of Tomcat and the ISAPI redirector.

I noticed some regressions which do not occur when using Tomcat 7.0.16
instead.


1) When declaring the CrawlerSessionManagerValve at Engine level in
server.xml:

<Valve className="org.apache.catalina.valves.CrawlerSessionManagerValve"/>

then I get a NPE when a client makes a request to Tomcat (or to IIS, which
is redirected to Tomcat by the ISAPI redirector):

03.07.2011 01:24:08 org.apache.catalina.connector.CoyoteAdapter service
SCHWERWIEGEND: An exception or error occurred in the container during the
request processing
java.lang.NullPointerException
	at
org.apache.catalina.valves.CrawlerSessionManagerValve.invoke(CrawlerSessionM
anagerValve.java:147)
	at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:404)
	at
org.apache.coyote.ajp.AjpAprProcessor.process(AjpAprProcessor.java:197)
	at
org.apache.coyote.ajp.AjpAprProtocol$AjpConnectionHandler.process(AjpAprProt
ocol.java:152)
	at
org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.run(AprEndpoint.java:
1731)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.ja
va:886)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:9
08)
	at java.lang.Thread.run(Thread.java:662)

This is because the uaPattern field in CrawlerSessionManagerValve is null.
With Tomcat 7.0.16, it works fine.


2) When using the ISAPI Redirector 1.2.32 and Tomcat Native 1.1.20 which is
included in the windows distribution, I get these errors when a client makes
a request to IIS which is redirected to Tomcat, resulting in 100% CPU usage
by tomcat's process:

03.07.2011 01:26:29 org.apache.tomcat.util.net.AprEndpoint$Poller run
SCHWERWIEGEND: Critical poller failure (restarting poller): [610038] APR
does not understand this error code

Sometimes, the entire Tomcat process crashes with an
EXCEPTION_ACCESS_VIOLATION in tcnative-1.dll:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000001001f43a,
pid=2260, tid=232
#
# JRE version: 6.0_26-b03
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.1-b02 mixed mode
windows-amd64 compressed oops)
# Problematic frame:
# C  [tcnative-1.dll+0x1f43a]
#

Also, this works fine with Tomcat 7.0.16 (also when using the included
Tomcat Native 1.1.20 and the ISAPI redirector 1.2.32): no crashes or
"critical poller failure" messages. Please note that the errors also occur
on a 32 bit Windows Server 2008 system.
These do not seem to occur with the HTTP APR connector. Also, when using the
AJP BIO instead of AJP APR, they don't occur.


I didn't see any reports for this on the dev list, so I thought I post them
here.


Regards,

Konstantin Prei├čer


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message