tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dharamshila Khandelwal <dharmshil...@gmail.com>
Subject Re: War file deployment deletes configuration descriptor in Tomcat 6
Date Wed, 08 Jun 2011 20:50:05 GMT
I found that when it deletes the configuration descriptor, it doesn't deploy
it.
I am not able to understand why it is not deploying the descriptor


Logs from catalina.out:

*When the configuration descriptor is not deleted: *

Jun 8, 2011 4:31:45 PM org.apache.catalina.startup.HostConfig checkResources
INFO: Undeploying context [/MOVE]
Jun 8, 2011 4:31:46 PM org.apache.catalina.startup.HostConfig
deployDescriptor
*INFO: Deploying configuration descriptor MOVE.xml*
Jun 8, 2011 4:31:46 PM org.apache.catalina.startup.HostConfig
deployDescriptor
WARNING: A docBase /opt/hsnweb/web94d/tomcat/webapps/MOVE inside the host
appBase has been specified, and will be ignored


*This is when configuration descriptor is deleted: *


Jun 8, 2011 4:44:18 PM org.apache.catalina.startup.HostConfig checkResources
INFO: Undeploying context [/MOVE]
Jun 8, 2011 4:44:20 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive MOVE.war




On Wed, Jun 8, 2011 at 1:47 PM, Dharamshila Khandelwal <
dharmshila.k@gmail.com> wrote:

> Hi,
>
> Every time I deploy war file in webapps, it deletes the configuration
> descriptor which is present at $CATALINA_BASE/conf/[enginename]/[hostname]
> directory.
> Tomcat auto deploys war file in my Tomcat 6 configuration.
>
> How should I stop this problem?
>
> Any idea?
>
> Thanks,
> DS.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message