tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: mod_jk problem
Date Tue, 14 Jun 2011 20:14:44 GMT
On 14.06.2011 13:07, Orgil Tulga wrote:
> Hello All,
>  
>   I am using apache and tomcat with mod_jk.
> apache version : 2.2.19
> tomcat version : 6.0
> mod_jk version : 1.2.30
>  
> My web runs through servlet.
>  
> http://domainname:8080/contact.shtml - is working
> http://domainname/contact.shtml - is not working
>  
> mod_jk log :
>  
> [debug] map_uri_to_worker_ext::jk_uri_worker_map.c (1036): Attempting to map URI '/contact.shtml'
from 4 maps
>  [trace] find_match::jk_uri_worker_map.c (839): enter
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/servlets/*=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/servlet/*=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/*.jsp=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/*=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (863): Found a wildchar match '/*=ajp13'
>  [trace] find_match::jk_uri_worker_map.c (866): exit
>  [trace] map_uri_to_worker_ext::jk_uri_worker_map.c (1065): exit
>  [trace] map_uri_to_worker_ext::jk_uri_worker_map.c (951): enter
>  [debug] map_uri_to_worker_ext::jk_uri_worker_map.c (1036): Attempting to map URI '/404.shtml'
from 4 maps
>  [trace] find_match::jk_uri_worker_map.c (839): enter
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/servlets/*=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/servlet/*=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/*.jsp=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/*=ajp13'
source 'JkMount'
>  [debug] find_match::jk_uri_worker_map.c (863): Found a wildchar match '/*=ajp13'
>  [trace] find_match::jk_uri_worker_map.c (866): exit
>  [trace] map_uri_to_worker_ext::jk_uri_worker_map.c (1065): exit
>  
> Why jk connector not converting to servlet? any idea?

In addition to the questions concrning your configuration: could it be
some other module in Apache already handles "*.shtml"?

Do you get error messages during startup of mod_jk in the mod_jk log
file? Or any errors in the Apache ErrorLog?

Regards,

Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message