tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Leone <midnightj...@verizon.net>
Subject Context Definition Doesn't Work
Date Fri, 10 Jun 2011 03:15:00 GMT
I've been running Tomcat since version 4. Today, running 7.0.12,  I 
decided to define a non-standard context, and I can't get it to work 
after carefully following all the instructions in the documentation and 
doing what all my searching confirmed I should be doing.

My web app is deployed at $CATALINA_HOME/webapps/filePort. I've been 
reaching it at http://myHost/filePort. Now I want to have a context of 
/mbp/filePort, because I want the web app to run on three separate 
Tomcat instances behind an apache server, using mod_jk to route to each 
Tomcat based on the first part of the context path.

So I have the file 
$CATALINA_HOME/conf/Catalina/localhost/mbp#filePort.xml, and inside this 
file is the following XML

<Context >
<WatchedResource>WEB-INF/web.xml</WatchedResource>
</Context>

In server.xml I have Engine "Catalina" and Host "localhost" defined, 
with no Context defined. I have no Context defined anywhere else. The 
appBase for Host "localhost" is defined as "webapps".

However, the web app is still reachable at http://myHost/filePort and 
not at http://myHost/mbp/filePort. For the latter URL, Tomcat reports 
that the requested resource is not available.

Even though it's not recommended, I tried defining a Context element in 
server.xml, inside the Host element, with path="/mbp/filePort" and 
docBase="filePort" but I got the same result.

Presumably I'm missing something here, but I've done what the 
documentation says to do, and it doesn't work.

-Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message