tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Wolf <tw...@hotmail.com>
Subject RE: java.lang.ClassNotFoundException - JSP pages
Date Mon, 23 May 2011 13:10:11 GMT

Hi all,
Here is a quick update of my situation:
 
I made two changes:
 

I set the checkInterval flag for the JspServlet settings (20 seconds)
I reduced my maxObjectInCache parameter (a proprietary application config) which basically
reduces the amount of memory my app uses
 
So far, I stopped getting the ClassNotFoundException.
 
I'll continue checking during this week, and then try removing the checkInterval flag from
one of my servers to see if this is the root cause.
 
If anyone has any tips, I'll appreciate it.
 
Thanks
 
> From: twb15@hotmail.com
> To: users@tomcat.apache.org
> Subject: java.lang.ClassNotFoundException - JSP pages
> Date: Sat, 21 May 2011 19:06:53 +0000
> 
> 
> Hi all,
> 
> I'm running Tomcat 6.0.26 on a Win2008 machine.
> I'm running three web-apps on a single instance.
> 
> After a few hours of running, I start getting java.lang.ClassNotFoundException when trying
to access certain JSP files.
> Other JSP files are accessible.
> I get this exception for pages on all three web-apps.
> 
> I checked with jconsole, and their are really no JSP compiled classes in memory for the
pages I try to access.
> 
> After restarting Tomcat, I manage to access these pages.
> 
> 
> 
> Another thing to note is that one of my web-apps is writing a lot of logs to catalina
- on purpose.
> 
> Any ideas? is it a memory problem? I'm thinking of working with separate Tomcat instances
per web-app.
> 
> Thanks 
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message