tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Braun <brianbr...@gmail.com>
Subject java.lang.NoClassDefFoundError: javax/servlet/jsp/jstl/core/LoopTag
Date Thu, 19 May 2011 15:16:03 GMT
Hi,

I feel like a rookie, But I will ask for help on this. I will swallow my
pride.
I'm using Eclipe (latest version) to develop, and Tomcat 7.0.X both in
development and in production. I started using JSTL1.2 today. When I run my
app, I get this response:

javax.servlet.ServletException: java.lang.NoClassDefFoundError:
javax/servlet/jsp/jstl/core/LoopTag
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:343)
javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
org.tuckey.web.filters.urlrewrite.RuleChain.handleRewrite(RuleChain.java:176)
org.tuckey.web.filters.urlrewrite.RuleChain.doRules(RuleChain.java:145)
org.tuckey.web.filters.urlrewrite.UrlRewriter.processRequest(UrlRewriter.java:92)
org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(UrlRewriteFilter.java:381)
org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1056)
org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:388)
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:231)
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1164)
org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:397)
javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
org.tuckey.web.filters.urlrewrite.RuleChain.handleRewrite(RuleChain.java:176)
org.tuckey.web.filters.urlrewrite.RuleChain.doRules(RuleChain.java:145)
org.tuckey.web.filters.urlrewrite.UrlRewriter.processRequest(UrlRewriter.java:92)
org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(UrlRewriteFilter.java:381)
I already added the file "jstl-impl-1.2.jar" to my "lib" path, which is
"C:\EclipseTomcat7Labs\webapps\VistaControlador\WEB-INF\lib". I confirmed
that when Eclipse is deploying my app, it is deloying the JST JAR. I also
put this declaration on top of my JSP file:
<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>

So how can that class not be found?

Thanks in advace,

Brian

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message