tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Slow SSL connections after Tomcat 5 to 7 migration
Date Wed, 04 May 2011 13:49:27 GMT
> From: Michał Kapituła [mailto:michal.kapitula@comarch.pl] 
> Subject: Slow SSL connections after Tomcat 5 to 7 migration

> I've just tested the page generation time via local network (and 
> browser's cache off) and the page is being fully loaded in circa 2 
> seconds (with Firebug on) when using http, while loading the same
> page using secure connection took as much as 10 times longer.

If the CPU usage is not high during page generation over SSL, and the network isn't inducing
delays, then the threads must be waiting for something.  Can you take some thread dumps during
the delay period and find out what they're stuck on?  (My suspicion is reads from /dev/random,
but I thought that was only during Tomcat initialization.)

Also, is Tomcat front-ended by anything (e.g., httpd), or are you accessing it directly?

Did anything else change when you upgraded Tomcat?  For example, the JVM version?

> Sorry for my English, for I'm not a native speaker :).

It's better than that of many who are...

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.

Mime
View raw message