tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fsman...@netscape.net
Subject Re: Tomcat 6.0.32 on 64-bit 2008 server - "Event 1000, Application Error"
Date Wed, 04 May 2011 17:01:47 GMT
It could - haven't figured that one out yet :)

More info:  After a couple starts and stops of the service, it was fine, so I decided to start
"customizing" Tomcat for the application I need to install.  Stopped Tomcat, added "-XX:MaxPermSize=256m"
and "-Xmx2048m" to the JVM options, and it won't start again.  After removing them and trying
to start Tomcat again, it still won't start.  I don't think those parameters are the cause
of the a problem - after the configuration was touched, it basically stops working.  Here's
the log snippet:

[2011-05-04 12:53:00] [debug] ( prunsrv.c:1494) Commons Daemon procrun log initialized
[2011-05-04 12:53:00] [info]  (          :0   ) Commons Daemon procrun (1.0.5.0 64-bit) started
[2011-05-04 12:53:00] [info]  (          :0   ) Running 'Tomcat6' Service...
[2011-05-04 12:53:01] [debug] ( prunsrv.c:1246) Inside ServiceMain...
[2011-05-04 12:53:01] [info]  (          :0   ) Starting service...
[2011-05-04 12:53:01] [debug] ( javajni.c:206 ) loading jvm 'C:\Program Files\Java\jre6\bin\server\jvm.dll'
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[0] -Dcatalina.home=C:\Program Files\Apache
Software Foundation\Tomcat 6.0
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[1] -Dcatalina.base=C:\Program Files\Apache
Software Foundation\Tomcat 6.0
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[2] -Djava.endorsed.dirs=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\endorsed
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[3] -Djava.io.tmpdir=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\temp
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[4] -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[5] -Djava.util.logging.config.file=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\conf\logging.properties
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[6] -XX:MaxPermSize=256m
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[7] -Djava.class.path=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2011-05-04 12:53:01] [debug] ( javajni.c:660 ) Jvm Option[8] -Xmx2048m
[2011-05-04 12:53:37] [debug] ( prunsrv.c:1494) Commons Daemon procrun log initialized
[2011-05-04 12:53:37] [info]  (          :0   ) Commons Daemon procrun (1.0.5.0 64-bit) started
[2011-05-04 12:53:37] [info]  (          :0   ) Running 'Tomcat6' Service...
[2011-05-04 12:53:37] [debug] ( prunsrv.c:1246) Inside ServiceMain...
[2011-05-04 12:53:37] [info]  (          :0   ) Starting service...
[2011-05-04 12:53:37] [debug] ( javajni.c:206 ) loading jvm 'C:\Program Files\Java\jre6\bin\server\jvm.dll'
[2011-05-04 12:53:37] [debug] ( javajni.c:660 ) Jvm Option[0] -Dcatalina.home=C:\Program Files\Apache
Software Foundation\Tomcat 6.0
[2011-05-04 12:53:37] [debug] ( javajni.c:660 ) Jvm Option[1] -Dcatalina.base=C:\Program Files\Apache
Software Foundation\Tomcat 6.0
[2011-05-04 12:53:37] [debug] ( javajni.c:660 ) Jvm Option[2] -Djava.endorsed.dirs=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\endorsed
[2011-05-04 12:53:37] [debug] ( javajni.c:660 ) Jvm Option[3] -Djava.io.tmpdir=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\temp
[2011-05-04 12:53:37] [debug] ( javajni.c:660 ) Jvm Option[4] -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
[2011-05-04 12:53:37] [debug] ( javajni.c:660 ) Jvm Option[5] -Djava.util.logging.config.file=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\conf\logging.properties
[2011-05-04 12:53:37] [debug] ( javajni.c:660 ) Jvm Option[6] -Djava.class.path=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar

 

 Is there something 64-bit related that I'm missing?  I've seen mentions about 64-bit and
setting environment variables, but setting JAVA_HOME to the JDK/JRE paths didn't help.  Is
there anything specific that needs to be set after you use the .exe installer for both Tomcat
and the JDK?


 

 

-----Original Message-----
From: André Warnier <aw@ice-sa.com>
To: Tomcat Users List <users@tomcat.apache.org>
Sent: Wed, May 4, 2011 12:34 pm
Subject: Re: Tomcat 6.0.32 on 64-bit 2008 server - "Event 1000, Application Error"


fsmaniac@netscape.net wrote: 
> > Also, do the out-of-order timestamps (and the server startup time of  -1161496934
ms) hint at anything? 
> Not that it has anything to do with the problem, but I would say that the startup time
looks very much like a formatting error.  Or else that hardware of yours is *really* fast.

May even explain the out-of-order timestamps, when you think about it. 
;-) 
 
--------------------------------------------------------------------- 
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org 
For additional commands, e-mail: users-help@tomcat.apache.org 
 

 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message