tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fsman...@netscape.net
Subject Tomcat 6.0.32 on 64-bit 2008 server - "Event 1000, Application Error"
Date Wed, 04 May 2011 13:22:13 GMT
Hi all,





 
                
Did a vanilla Tomcat 6.0.32 install (.exe package) on a 64-bit Windows 2008 R2 server.  The
service starts and stops fine, but after a while (say, roughly one day), I get the following
error message in Windows' Application log when trying to start Tomcat from a stopped state.
 The title of the error is "Event 1000, Application Error":



Faulting application name: tomcat6.exe, version: 1.0.5.0, time stamp: 0x4d245ac2
Faulting module name: jvm.dll, version: 19.1.0.2, time stamp: 0x4d4a214c
Exception code: 0xc0000094
Fault offset: 0x000000000051f48f
Faulting process id: 0x9d0
Faulting application start time: 0x01cc0a5acc256cf0
Faulting application path: C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\tomcat6.exe
Faulting module path: C:\Program Files\Java\jre6\bin\server\jvm.dll
Report Id: 09f73d92-764e-11e0-af4a-005056a10003



And from commons-daemon.log:
[2011-05-04 08:57:17] [debug] ( prunsrv.c:1494) Commons Daemon procrun log initialized
[2011-05-04 08:57:17] [info]  (          :0   ) Commons Daemon procrun (1.0.5.0 64-bit) started
[2011-05-04 08:57:17] [info]  (          :0   ) Running 'Tomcat6' Service...
[2011-05-04 08:57:17] [debug] ( prunsrv.c:1246) Inside ServiceMain...
[2011-05-04 08:57:17] [info]  (          :0   ) Starting service...
[2011-05-04 08:57:17] [debug] ( javajni.c:206 ) loading jvm 'C:\Program Files\Java\jre6\bin\server\jvm.dll'
[2011-05-04 08:57:17] [debug] ( javajni.c:660 ) Jvm Option[0] -Dcatalina.home=C:\Program Files\Apache
Software Foundation\Tomcat 6.0
[2011-05-04 08:57:17] [debug] ( javajni.c:660 ) Jvm Option[1] -Dcatalina.base=C:\Program Files\Apache
Software Foundation\Tomcat 6.0
[2011-05-04 08:57:17] [debug] ( javajni.c:660 ) Jvm Option[2] -Djava.endorsed.dirs=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\endorsed
[2011-05-04 08:57:17] [debug] ( javajni.c:660 ) Jvm Option[3] -Djava.io.tmpdir=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\temp
[2011-05-04 08:57:17] [debug] ( javajni.c:660 ) Jvm Option[4] -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
[2011-05-04 08:57:17] [debug] ( javajni.c:660 ) Jvm Option[5] -Djava.util.logging.config.file=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\conf\logging.properties
[2011-05-04 08:57:17] [debug] ( javajni.c:660 ) Jvm Option[6] -Djava.class.path=C:\Program
Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar




Latest 64-bit JDK (jdk-6u24-windows-x64.exe) is also installed, Windows' UAC and DEP is disabled.
 The worst part is that a reboot doesn't solve the problem.  Starting from a cold boot gives
the same error.  Thankfully the machine is a VM, so I can revert back to a known-good state...
but this basically seems to act as a time-bomb of sorts.  If I don't do any stopping/starting
after some period of time, Tomcat will permanently stay down the next time the service is
stopped.

Thoughts?  Any help is greatly appreciated.
            

 
 

=

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message