tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: 100% CPU Usage when stopping Tomcat after OOM condition
Date Tue, 03 May 2011 14:46:39 GMT
Mark Thomas wrote:
> On 03/05/2011 15:22, Christopher Schultz wrote:
>> All,
>>
>> Moments ago in our development environment, our webapp suffered an OOME
>> after many re-reployments (we know we have an undeploy-related leak).
>> When attempting to bounce Tomcat, the shutdown failed and I took a
>> thread dump which included the one non-trivial thread shown below.
>>
>> I haven't looked at the code yet to see if there is some kind of loop
>> around this code, but top reported 100% CPU usage from this process so I
>> suspect something like that was happening.
>>
>> We are using TC 6.0.32 on Debian Lenny and Sun/Oracle 32-bit
>> 1.6.0_22-b04 Server VM.
>>
>> This is less of a "help" request as it is an observation of an
>> unfortunate situation: the OOME is clearly the real problem and has
>> nothing to do with Tomcat itself. Unfortunately, after the OOME, Tomcat
>> was unable to shut down gracefully and that could be a problem in and of
>> itself.
> 
> After an OOME there are no guarantees as to the state of the JVM. That
> Tomcat is unable to shut down cleanly in that case is not suprising.
> 
Do I not remember seeing somewhere, at some point, a parameter named "OOMParachute" or 
similar ?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message