tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Tomcat 6 Struts 1.3
Date Mon, 02 May 2011 14:12:18 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

cpanon,

On 5/1/2011 7:31 PM, cpanon wrote:
> I have an odd but systemic problem with an otherwise working implementation.  I 
> am unable to get any technique to dynamically recalculate a page from an 
> action.  I have tried the following
> 1.  Defined a frameset with the "top" frame specified in realtime with jstl.  It 
> works the first time, there after even though I am positive I ave set the 
> elements in my form bean for the new jsp, it fails to recalculate and show the 
> different jsp.  The second time is, of course the exact same approach that works 
> the first time, nothing changes and neither does the inclusion of the new jsp 
> the second time.
> 2.  Tiles.  Defined a template, this time without a frameset, very standard 
> header, body, footer.  Defined tiles-defs.xml  to extend the template and just 
> change the put for the body.  Again it does not recalculate, reprocess the 
> page.  How can this be.  I am successfully forwarding the first time to a 
> definition in the tiles-defs.  The second time I am also doing the same, 
> forwarding to a definition in tiles-defs and it does not work;I see the old 
> previous result.  
> 
> 3.  jsp:include.  Define another template that simulates the Tiles approach but 
> rather than named areas more primitively makes three rows in a table and uses 
> jstl to pick off the correct jsp for that section.  Again it fails after the 
> first time.  Even thought I specify a different name for the body, set it in the 
> form bean, specify it as jsp:include page=${sessionScope.formBean.bodyName}, it 
> does not work, after the first time.  Of course even when I first remove the 
> formbean and populate it and add it to the session.  

How about a larger portion of sample code, and an example of the HTML
output that /does/ work versus one that doesn't.

> How can I be having this systemic problem not alleviated by any of the different 
> designs?  Any one of these should have  worked.  To have all of them fail has 
> cost me many days and worse.  Any help appreciated.  

My suspicion is that you are not using URLs that start with "/" and are
always rooted at the webapp's base. If you try to use relative URLs like
"../whatever" or "whatever/" then you will have weird problems because
the base path of the resource changes depending on what page the browser
is on.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk2+u8IACgkQ9CaO5/Lv0PDB9QCffZA91popTl/44CKGRuo5gcDY
21AAoKJZFtoq721UEm/M7zufZTiqkoRC
=eBP0
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message