tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Seymour <jseym...@LinxNet.com>
Subject Cannot find daemon loader org/apache/commons/daemon/support/DaemonLoader
Date Tue, 10 May 2011 20:16:53 GMT
Good Day,

The vital info:

    Apache-Tomcat 6.0.32
    Java 1.5.0_22
    Sun Sparc Solaris 8 (SunOS 5.8 Generic_117000-05 sun4u)
    Ant 1.8.2
    GCC 3.4.6

Did everything just like the docs all said to do, and the result of
trying to start-up jsvc is:

    "Cannot find daemon loader
        org/apache/commons/daemon/support/DaemonLoader"

The outputs to the screen and to the logfile, with -debug, are attached.

$ jar tf /usr/local/share/tomcat6/bin/commons-daemon.jar |\
      grep 'DaemonLoader'
org/apache/commons/daemon/support/DaemonLoader$1.class
org/apache/commons/daemon/support/DaemonLoader$Controller.class
org/apache/commons/daemon/support/DaemonLoader$Context.class
org/apache/commons/daemon/support/DaemonLoader.class

Everything, everywhere, is 755 or 775 for directories, and 664 or 644
for files.  (The above "jar | grep" was executed as a user with no
special privs.)

I followed a thread where a guy running Sparc Solaris 10 had the same
problem, tho he was trying to use 32-bit everything, for some reason.
I've just built everything with whatever the defaults were.  I did try
the "-m64" and other switches recommended by Mladen Turk-3.  No joy.
(That thread never seemed to reach closure.)  I even tried the jsvc
from the daemon-1.0.1.tar.gz tarball, which worked for the guy in that
thread. No joy there, either.

Suggestions?

Thanks In Advance,
Jim 
-- 
Note: My mail server employs *very* aggressive anti-spam
filtering.  If you reply to this email and your email is
rejected, please accept my apologies and let me know via my
web form at <http://jimsun.LinxNet.com/contact/scform.php>.


Mime
View raw message