tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter P. Lupo" <ppl...@gmail.com>
Subject Re: Hard time finding a but on Tomcat 7 (doesn't happen on 6.)
Date Sat, 02 Apr 2011 16:47:56 GMT
Just reporting back that the issue was related to JDK 7 beta. It would only
happen with Tomcat 7, not 6, but it seems to be JVM's fault, not Tomcat's
fault.

Sorry for the inconvenience. Thank you for the assitance.

Regards,

Peter P. Lupo
http://craftnicely.blogspot.com - http://sites.google.com/site/pplupo
 <http://sites.google.com/site/pplupo>MPS.BR Authorized Implementation
Practitioner<http://www.softex.br/mpsbr/_profissionais/MPS.BR_certificados_de_arovacao_prova_P2-MPS.BR.pdf>-
Certified
ScrumMaster <http://www.scrumalliance.org/pages/certified_scrummaster>
 <http://www.scrumalliance.org/pages/certified_scrummaster>Oracle Certified
Associate, Java SE 5/SE
6<http://in.sun.com/training/certification/java/scja.xml> -
Java Black Belt <http://www.blackbeltfactory.com/ui#!User/pplupo>
 <http://www.blackbeltfactory.com/ui#!User/pplupo>+55 (021) 81742487



On Thu, Mar 17, 2011 at 12:28 PM, Konstantin Kolinko <knst.kolinko@gmail.com
> wrote:

> 2011/3/17 Caldarale, Charles R <Chuck.Caldarale@unisys.com>:
> >> From: Peter P. Lupo [mailto:pplupo@gmail.com]
> >> Subject: Re: Hard time finding a but on Tomcat 7 (doesn't happen on 6.)
> >
> >> I found some logs on eclipse root regarding the error Im
> >> having on tomcat (Im running tomcat from eclipse).
> >
> > The logs contain a major hint:
> >
> > # JRE version: 7.0-b125
> > # If you would like to submit a bug report, please visit:
> > #   http://java.sun.com/webapps/bugreport/crash.jsp
> >
> > You broke the JVM.  You might want to use a supported JVM, not an
> experimental one.
> >
>
> As suspected.
>
> Regarding "Exception in thread "" messages
> 1) I am sure that those are printed by ThreadGroup.uncaughtException(..).
>
> 2) There should have been a stacktrace following them. Looking into
> Throwable.printStackTrace(), there is a synchronized block there
> against the stream it is writing to. It looks as if the threads are
> not able to enter that block.
>
> > Also, I'd strongly recommend that you do *not* run Tomcat under Eclipse -
> the IDEs like to do their own configuration and hide things - as you just
> found out.
>
> Nothing wrong with that. You just have to know what those things are.
>
> http://wiki.eclipse.org/WTP_Tomcat_FAQ
>
> Best regards,
> Konstantin Kolinko
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message