tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Strauß <t.stra...@srs-management.de>
Subject AW: Solved: Issue with isapi_redirect-1.2.31 on IIS7 on Win2008R2
Date Mon, 04 Apr 2011 11:19:10 GMT
For whom it may concern.

The issue is solved. The problem were missing access rights to the folders
containing the dll. The issue is, that we cannot see what rights were not
sufficient. 

Adding the IIS site runner to admin group did not help, only adding read
access for everyone made IIS read the DLL on startup again. Funny enough,
later on, when the site was started up, we could see the DLL load and being
accessed - but the DLL was not active (redirect did not happen). All Test
access buttons of IIS7 reported no issue. Maybe the runtime user of the II7
service itself has changed. 

Hope this helps someone else in the same situation...

Regards,

Thomas

-----Ursprüngliche Nachricht-----
Von: Thomas Strauß [mailto:t.strauss@srs-management.de] 
Gesendet: Samstag, 2. April 2011 12:48
An: Tomcat Users List
Betreff: Re: Issue with isapi_redirect-1.2.31 on IIS7 on Win2008R2

Hi,

Answering myself ...

found a blog entry that points to a direction
http://blogs.msdn.com/b/david.wang/archive/2005/06/21/howto-diagnose-and-fix
-common-isapi-filter-installation-failures.aspx?PageIndex=5.

The return code is not 00000005, it is 05000000 and this is in fact an
ACCESS_DENIED response. I still do not know why the service suddenly refuses
to load the formerly running dll, but will try to run a process monitor. I
will post here if the issue is solved - as a kind of archive of things that
can happen...

Regards,


Thomas


Am 01.04.2011 um 18:18 schrieb Thomas Strauß:

Hi,

we have a customer that is facing a situation since yesterday on two 2008R2
servers.

The IIS did without warning refuse to load the isapi_redirect-1.2.31 dll.

The error is always the same:
   Could not load all ISAPI filters for site <'the site name>'.  Therefore
site startup aborted.
  The HTTP Filter DLL
D:\PaperDynamix\IIS-Redirect\bin\isapi_redirect-1.2.28.dll failed to load.
The data is the error.

The error code in the data is 0000005

The system ran in this configuration for four month now without change on
the IIS configuration.  We replaced the redirector with the .31 version, but
this was also not loaded.

The eventlog only shows the issue above, everything else is fine. The tomcat
servers behind the IIS are running fine – no issue there. The version of the
DLL is definitely x64, we think there has been a global policy change on the
Windows domain, but this is neglected, customer says, that policies have not
been changed for some weeks.

On the server, McAFFEE is installed, but it does not report anything, nor
does it deny loading any file (not reported at least). We cannot see any
traces of any crash.

Does anyone know of a Servicepack / Bugfix installed on the Domain
Controller that may propagate this change to domain members?
On the server, UAC is active, but there is no login failure in the audit
event log, so no trace of an issue there.

Is anyone aware of such an issue or can anyone point me to something?

What happened yesterday at around 02:00 PM?

Mit freundlichen Grüßen

Thomas Strauß
Geschäftsführer Entwicklung

SRS PaperDynamix®
DIGITAL SCHON AUF DEM PAPIER

SRS-Management GmbH
Berliner Ring 93
64625 Bensheim
T +49 6251 85 424 - 20
F +49 6251 85 424 - 14
M +49 174 2110912

www.srs-management.de<http://www.srs-management.de>
www.srs-paperdynamix.de<http://www.srs-paperdynamix.de>

HRB 25262 AG Darmstadt
Geschäftsführer: Detlev Homilius, Thomas Strauß




-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


Mime
View raw message