tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Tomcat 7 Startup Problems
Date Mon, 11 Apr 2011 13:39:43 GMT
Joseph Morgan wrote:
> We downloaded and installed apache-tomcat-7.0.8.exe install for Windows from the Apache
site, and installed as we normally do, from the EXE, and, as you presume, as a service.
> 
> We normally start it via the Tomcat monitor, but of course that isn't working.  So, from
the command line in the "bin" directory, we are running, simply, "tomcat7.exe".... and it
is from that we see the message.  Now that I take a closer look at the bin dir... there isn't
a "startup.bat". 
> 

Right. Then, in short : run "tomcat7w.exe", which should be there. That's a GUI which 
allows to edit parameters stored in the Registry, for the "Tomcat JVM wrapper" which is 
"tomcat7.exe".
In one of the tabs, there should be the path of the JVM to run, and that's probably what 
is wrong. Rectify it and retry tomcat7.exe.

I'm not familiar with Tomcat7, but that's how it used to be for 5 and 6.

> 
> -----Original Message-----
> From: André Warnier [mailto:aw@ice-sa.com] 
> Sent: Monday, April 11, 2011 7:40 AM
> To: Tomcat Users List
> Subject: Re: Tomcat 7 Startup Problems
> 
> Joseph Morgan wrote:
>> We have a newly installed Tomcat 7 64bit in Windows 7 (quad-core w/8gb
>> ram, 322GB free disk space)
>>
> 
>  From where did you download / install it ?
> How did you install it ?
> 
>>  
>>
>> We copied the msvcr71.dll into the bin directory, and have Java
>> 1.6.0_23-b05 64 bit.
>>
>>  
>>
>> Tomcat doesn't start, 
> 
> How do you start it ?
> 
> and all we get from it is:
>> Service 'tomcat7' is missing the ImageFile
>>
> Where do you get that message ?
> 
> Presuming it is installed as a Windows Service, what does the Windows "Services applet"

> show for this service ? (as an executable file)
> 
> If you open a command window and navigate to Tomcat's installation directory, and enter

> "bin/starstup.bat", what do you see ?
> 
> 
>>  
>>
>> None of the normal Tomcat logs are written even with debug set on, so
>> it's clear the basics of Tomcat can't seem to get going...
>>
>>  
>>
>> Any ideas are appreciated.
>>
>>  
>>
>> Joe
>>
>>  
>>
>>  
>>
>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message