tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cha <eric.cha.r...@gmail.com>
Subject Re: url-pattern algorithm problem?
Date Fri, 01 Apr 2011 16:20:24 GMT
'>' is a copy&paste error sorry.  Yes, I do have filters but there is 
not url rewrite at all.

Turning on the debug on tomcat, it is return 404.

If I changing the pattern to /en/yp/* for that incoming url, it will 
work but it doesn't conform to what the spec said though.

Regards,
Cha.

On 04/01/2011 12:05 PM, Konstantin Kolinko wrote:
> 2011/4/1 Cha<eric.cha.read@gmail.com>:
>> Hello,
>>
>> We are using Tomcat 7.0.11 with the following servlet-mapping
>>
>> <servlet-mapping>
>> <servlet-name>app</servlet-name>
>> <url-pattern>*.htm</url-pattern>
>> <url-pattern>/en/*</url-pattern
> Missing '>'.
>
> Do you have a Filter that catches such requests and rewrites the URL?
> If you do, then the request will never reach the servlet.
>
>> </servlet-mapping>
>>
>> The problem we find if the incoming url is like
>> "http://example.com/en/yp/list/cat/10/1", it will not matched to the 'app'
>> servlet.  Any ideas?  Could it be a problem in tomcat matching algorithm?
> Best regards,
> Konstantin Kolinko
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message