tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keshav Arora <karor...@gmail.com>
Subject Error in Tomcat when redeploying the Web application
Date Wed, 02 Mar 2011 19:39:54 GMT
Hi All,

We have been using Tomcat version 6.0.29 to deploy our webapp and everything
works great. In our development environment we can deploy/undeploy our web
app multiple times without getting any errors in Tomcat.

Recently we switched to Tomcat 7.0.8 and every time we redeploy our
application in Tomcat, we get the the following error in the
tomcat7-stderr.log file

SEVERE: Parse error in context.xml for /webapp
java.util.zip.ZipException: invalid block type
    at java.util.zip.InflaterInputStream.read(Unknown Source)
    at java.util.zip.InflaterInputStream.read(Unknown Source)
    at java.io.FilterInputStream.read(Unknown Source)
    at
com.sun.org.apache.xerces.internal.impl.XMLEntityManager$RewindableInputStream.read(Unknown
Source)
    at
com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(Unknown
Source)
    at
com.sun.org.apache.xerces.internal.impl.XMLVersionDetector.determineDocVersion(Unknown
Source)
    at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
    at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
    at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
    at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown
Source)
    at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown
Source)
    at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1543)
    at
org.apache.catalina.startup.ContextConfig.processContextConfig(ContextConfig.java:630)
    at
org.apache.catalina.startup.ContextConfig.contextConfig(ContextConfig.java:587)
    at
org.apache.catalina.startup.ContextConfig.init(ContextConfig.java:834)
    at
org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:335)
    at
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
    at
org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:89)
    at
org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:343)
    at
org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:323)
    at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:107)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:136)
    at
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:812)
    at
org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:787)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:607)
    at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:925)
    at
org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:723)
    at
org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:470)
    at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1343)
    at
org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:294)
    at
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
    at
org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:89)
    at
org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1235)
    at
org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1393)
    at
org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1403)
    at
org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1382)
    at java.lang.Thread.run(Unknown Source)

To make our application work, we need to stop the Tomcat service and start
it again.

Can anyone suggest whats causing this problem?

Thanks,
Keshav

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message