tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tomcat failing to process JAR's within web app
Date Fri, 04 Mar 2011 20:53:51 GMT
2011/3/4 McGibbney, Lewis John <Lewis.McGibbney@gcu.ac.uk>:
> 04-Mar-2011 19:51:31 org.apache.catalina.startup.TldConfig tldScanJar
> WARNING: Failed to process JAR [jar:jndi:/localhost/wombra/WEB-INF/lib/commons-io-1.4.jar!/null]
for TLD files
> java.io.IOException: No such file or directory
> ...
> etc
> ...
> many more
> ...
> for all of the jar files I have within myWebApp/WEB-INF/lib.
>
> I have the exact same jar files in my webApp home dir as I do within the WAR file I put
in the $CATALINA_HOME/webapps directory. The file located within $CATALINA_HOME/conf/Catalina/localhost
reads as follows
>
> <?xml version="1.0" encoding="utf-8"?>
> <Context docBase="/home/lewis/Downloads/wombra/wombra.war" crossContext="true"

According to the docBase attribute in your wombra.xml, your war file
must be /home/lewis/Downloads/wombra/wombra.war I suspect that there
is no such file.  And wombra.xml takes precedence over
webapps/wombra.war.

Thus either remove the file from webapps, or remove the docBase
attribute. You cannot have both (see the configuration reference for
Context).

Also consider upgrading to 7.0.8.

>
>  <Environment name="solr/home" type="java.lang.String" value="/home/lewis/Downloads/wombra"
override="true"/>
> </Context>
>

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message