tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Can't move files using symbolic links (allowLinking=true)
Date Mon, 21 Mar 2011 13:54:05 GMT
Goyo wrote:
>  Hi.
> I need to use a symbolic link to access a certain path in my server, where
> I'm using Jakarta Tomcat 4.1.18.

Oh, a real old-timer, he ? You know how old this is, right ? I think some people on this 
list may still have been in primary school when it was released.
See http://tomcat.apache.org/whichversion.html
(and 4.1.18 is from 2003, as far as I can tell)

> We stablished a symbolic link to another path. At first, tomcat didn't see
> this path through the symlink, but we searched for it and found the
> allowLinking=true feature.
> Now, it sees the path. However, and here comes the problem, it doesn't allow
> to move files to this path.
> We've tried to move files manually with the same user of tomcat and it works
> well, but it doesn't via the web application. Besides, this feature worked
> perfect before making this folder reachable through a symlink.
> 

Can you explain more precisely what you mean by "moving files" ? (who is doing the moving,

from where to where, using what,..)
(and maybe also tell us which platform this Tomcat is running on, etc..)

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message