tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Strauß <t.stra...@srs-management.de>
Subject Re: IIS6 not forwarding requests to Tomcat 5.5
Date Sat, 12 Feb 2011 21:55:23 GMT
Hi,

where have you setup the connector properties? In the registry? Can you provide those settings?

They also contain the location of the redirector logfile and loglevel.

If you get that far, you can always install the jkstatus worker to allow you to test the redirector
functionality.


Regards,


Thomas

Am 11.02.2011 um 14:33 schrieb Sebastian Szuber:

> I've installed Wireshark and indeed there is no network traffic
> flowing from IIS to AJP Connector, while it catches my other
> connection I did using telnet.
> 
> But how do I find what's wrong with my IIS6 config?
> I've found IIS error log in systemroot\System32\LogFiles\HTTPERR
> folder but no errors there, also nothing in EventViewer.
> 
> Can someone have a look at IIS config screen shots?
> https://picasaweb.google.com/madperro/IISTomcat?authkey=Gv1sRgCLC69v6XrszBHQ#
> 
> Regards,
> Sebastian
> 
> 
> 
> 2011/2/11 Sebastian Szuber <madperro@gmail.com>:
>> Hi!
>> 
>> You can see screen shots with ISAPI Filter, Virtual Directory and
>> Extension configurations using this link:
>> https://picasaweb.google.com/madperro/IISTomcat?authkey=Gv1sRgCLC69v6XrszBHQ#
>> 
>> I've found only IIS access log entry with my request like this:
>> #Software: Microsoft Internet Information Services 6.0
>> #Version: 1.0
>> #Date: 2011-02-11 04:56:28
>> #Fields: date time s-sitename s-computername s-ip cs-method
>> cs-uri-stem cs-uri-query s-port cs-username c-ip cs-version
>> cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus
>> sc-win32-status sc-bytes cs-bytes time-taken
>> 2011-02-11 04:56:28 W3SVC1 <HOSTNAME> 127.0.0.1 GET
>> /analytics/res/Salsa_Glossary_en.htm - 80 - 127.0.0.1 HTTP/1.1
>> Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727)
>> nQuireID=6k2tvpltgiqfp0k1hvrmvaa0ahimnf9mjhvs7qizOr07UFe9W00;+sawU=<username>;+JSESSIONID=C4D5E330BADB7B722CC8C330D669D460
>> - localhost 404 2 1260 1795 414 796
>> 
>> But none any errors logged at least in Windows Event Viewer. Is there
>> any other place that I shall check for errors logged?
>> 
>> Pozdrawiam, S.
>> 
>> 
>> 
>> 2011/2/11 Mladen Turk <mturk@apache.org>:
>>> On 02/11/2011 10:09 AM, Sebastian Szuber wrote:
>>>> 
>>>> Andre,
>>>> 
>>>> HTTP Connector is listening to HTTP protocol on 8080 port - I've used
>>>> it to access Tomcat directly from the browser (without IIS) just to
>>>> check if Tomcat works.
>>>> So results shown in points 2 and 3 do not go through IIS.
>>>> 
>>>> When I request page through IIS - don't see anything on this fact in
>>>> Tomcat logs.
>>>> 
>>> 
>>> Seems like you IIS is not well configured.
>>> Filter seems to work, but not extension.
>>> Check the IIS log. It should have error there.
>>> 
>>> Where is /jakarta virtual dir defined and do you
>>> have all permissions set up.
>>> 
>>> 
>>> Regards
>>> --
>>> ^TM
>>> 
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>> 
>>> 
>> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> -- 
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message