tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shoaib M. Chaudhary" <muhammad.sho...@live.com>
Subject Re: mod_jk load balancing problem
Date Thu, 27 Jan 2011 05:02:27 GMT
Hello,

The problem I detected is that client has to send three requests for home
page as it contains frames. How can I force mod_jk to send all requests to
one server.

I come to this result while I shutdown one server called tomcat3 and restart
a tomcat on that machine (tomcat3) with no application. Frames showed error
404 that should be there as there were no page on that machine (tomcat3). I
concluded that all request is not been treated by one server.

Can someone help me out.

Regards
*Muhammad Shoaib*




On Thu, Jan 27, 2011 at 09:08, Shoaib M. Chaudhary <muhammad.shoaib@live.com
> wrote:

> The problem is following,
>
> When I use mod_jk with the following code for one worker it works fine but
> when I try to connect with two tomcat servers that are not on the same
> machine on which I have apache. Interestingly when I use one worker as
> localhost it works fine again.
>
> There is no error but the page loads again and again. following is my
> worker.properties file.
>
> worker.list=loadbalancer
>
> worker.tomcat2.port=8009
> worker.tomcat2.host=172.16.10.21
> worker.tomcat2.type=ajp13
> worker.tomcat2.lbfactor=1
> worker.tomcat1.socket_timeout=1000
>
>
> worker.tomcat3.port=8009
> worker.tomcat3.host=172.16.10.22
> worker.tomcat3.type=ajp13
> worker.tomcat3.lbfactor=1
> worker.tomcat1.socket_timeout=1000
>
>
> worker.loadbalancer.type=lb
> worker.loadbalancer.balanced_workers=tomcat2, tomcat3
>
> Intrestingly when I use worker.loadbalancer.balanced_workers=tomcat2 it
> works fine even if I replace tomcat2 with tomcat 3 as well. The page keep
> refreshing it self for some time and suddenly it finished refreshing and I
> can see the original page as well.
>
> Regards
> *Muhammad Shoaib*
>
> Software Engineer
> National University of Computer and Emerging Sciences
> A. K. Brohi Road (Near Police Line) H11/4 Islamabad
>
> Semantic Web Consultant / Knowledge Engineer
> Allainet Cooperation Private Limited
> I8/3 Islamabad Pakistan
>
> T +92-(51)-111-128-128 Ext 344 | M +92-334-5577712
> muhammad.shoaib@live.com
>
>
>
>
> On Wed, Jan 26, 2011 at 03:18, Michael Ludwig <milu71@gmx.de> wrote:
>
> > Shoaib M. Chaudhary schrieb am 26.01.2011 um 15:48 (+0500):
> >
> > > I am trying to use mod_jk with tomcat 5.5.3x. When I use mode_jk with
> > > one worker it works fine
> >
> > Okay.
> >
> > > but when I use loadbalancer with two different tomcats the server
> > > doesn't response
> >
> > No response at all? Or some error status?
> >
> > > but always try to refresh the page.
> >
> > It's not clear to me what you're doing nor what's happening.
> >
> > What about providing a more precise description of your setup (like
> > config) and observations?
> >
> > --
> > Michael Ludwig
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message