tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Problem with standard taglibs after precompiling a web app with TCD in 7.0.6 & no support for "addWebXmlMappings" in jasper
Date Mon, 31 Jan 2011 12:04:31 GMT
2011/1/31 John Bargos <jbargos12@gmail.com>:
> Hi,
>
> last week, I was having fun with trivial examples accessing a
> datasource with the standard taglibs with success.
> Since everything was working perfectly in jsp form and morale was high,
> I decided to precompile my web app with TCD and deploy it again in tomcat 7.0.6
>
> I installed ant, fetched dependencies, installed TCD set up the
> project's properties and fired "ant compile" away.
>
> 2 questions:
>
> A small problem appeared with addWebXmlMappings="true". apparently ant reported:
>
> \build.xml:67: jasper doesn't support the "addWebXmlMappings" attribute

That is strange, because
1) org.apache.jasper.JspC has setAddWebXmlMappings(boolean) method, so
it should not fail

2) The jasper call in build.xml (from
apache-tomcat-7.0.6-deployer.zip) is on lines 58-62, not on line 67 as
in the message.



> Apparently ant 1.8.2 with all dependencies fetched *today* isn't enough?

>
> java.lang.NullPointerException
>     at org.apache.jasper.runtime.
> TagHandlerPool.get(TagHandlerPool.java:106)
>     at index_jsp._jspx_meth_sql_query_0(Unknown Source)

1) Can you compare the java source of index_jsp._jspx_meth_sql_query_0
when generated by TCD and the one generated when index.jsp is compiled
at run time?
2) Please create a bugzilla entry.

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message