tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey Janner <Jeffrey.Jan...@PolyDyne.com>
Subject RE: Tomcat 5.5 on Windows Server 2008
Date Thu, 27 Jan 2011 17:52:33 GMT
Oops, that IPv6 address is supposed to be just "[::]".
I accidently appended the port to it (and the wrong one at that).
Jeff

> -----Original Message-----
> From: Jeffrey Janner [mailto:Jeffrey.Janner@PolyDyne.com]
> Sent: Thursday, January 27, 2011 11:50 AM
> To: 'Tomcat Users List'
> Subject: RE: Tomcat 5.5 on Windows Server 2008
> 
> Mark is correct below.  It is an IPV4 vs. IPV6 thing.
> It's a known issue if using the native libs.
> If you do not specify an IP address in the <connector> tag, then APR
> will only listen on IPV6.  If you disable the APR library (native) then
> it will work as expected, that is, it will listen on both "0.0.0.0" and
> "[::]:0".
> If you only need IPV4, you add 'address="0.0.0.0"' to the connector.
> It's been covered on this list previously - several times.  I am not
> positive if a bugzilla entry has been created for this.
> Jeff
> 
> > -----Original Message-----
> > From: Mark Thomas [mailto:markt@apache.org]
> > Sent: Thursday, January 27, 2011 11:27 AM
> > To: Tomcat Users List
> > Subject: Re: Tomcat 5.5 on Windows Server 2008
> >
> > On 27/01/2011 17:23, Pete Helgren wrote:
> > > I can't quite figure out what the issue is here but perhaps someone
> > who
> > > is running Tomcat 5.5 on Windows server 2008 can weigh in.  I have
> > > installed Tomcat 5.5 on a Windows Server 2008 64 bit OS.
> Everything
> > > seemed to install correctly.  I was able to bring up the site on
> > > localhost:8080 and on ServerName:8080 but, curiously, couldn't
> bring
> > it
> > > up on the IP Address of the server itself 192.168.1.200:8080
> > >
> > > I didn't think much of it and told the customer that they should be
> > able
> > > to access the site with either the internal IP or the internal DNS
> > name
> > > (the site in an Intranet site).  Turns out that the site CANNOT be
> > > accessed from anywhere BUT the server itself.  The firewall is NOT
> > > running and IIS is running.  Tomcat is not running behind IIS.
> > >
> > > Shouldn't I be able to access Tomcat running on the server from
> > anywhere
> > > on the internal network?  The tech I have been working with swears
> > that
> > > there is no firewall running anywhere.  This is a new installation.
> > I
> > > have had no issues on Windows 2003 so I suspect this is unique to
> > 2008
> > > but for all my searching of the Internet, I haven't found a
> solution.
> > > Anyone seen this before?   I *suspect* that IIS is somehow
> > controlling
> > > all http traffic, regardless of port but I can't seem to find any
> > hard
> > > evidence of this.
> > >
> > > Suggestions?  I am at a loss.
> >
> > netstat
> >
> > Find out what processes are listening on what addresses & ports.
> >
> > It might be an ipv4/ipv6 issues. If it is, try setting the address to
> > "0.0.0.0" in the connector.
> >
> > Mark
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org
> >
> 
> _______________________________________________________________________
> ___
> 
> Confidentiality Notice:  This Transmission (including any attachments)
> may contain information that is privileged, confidential, and exempt
> from disclosure under applicable law.  If the reader of this message is
> not the intended recipient you are hereby notified that any
> dissemination, distribution, or copying of this communication is
> strictly prohibited.
> 
> If you have received this transmission in error, please immediately
> reply to the sender or telephone (512) 343-9100 and delete this
> transmission from your system.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 

__________________________________________________________________________

Confidentiality Notice:  This Transmission (including any attachments) may contain information
that is privileged, confidential, and exempt from disclosure under applicable law.  If the
reader of this message is not the intended recipient you are hereby notified that any dissemination,
distribution, or copying of this communication is strictly prohibited.  

If you have received this transmission in error, please immediately reply to the sender or
telephone (512) 343-9100 and delete this transmission from your system.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message