tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tore Wilhelm Hermansen <tore.herman...@ntnu.no>
Subject Can't load APR on Tomcat 6.0.24, RedHat Enterprise Linux 6.0 x86_64 with Sun Java 1.6.0_22
Date Wed, 19 Jan 2011 13:51:44 GMT
Hi.
I can't get Tomcat (6.0.24) to load APR. I've tried installing the apr,
apr-devel, apr-util, apr-util-devel and apr-util-mysql package from
RedHat. I've also tried compiling/installing APR downloaded from
http://apr.apache.org/ (apr-1.4.2).
libapr-1.so from the RedHat package is present in /usr/lib64, readable
and executable by all. libapr-1.so I compiled myself is present
in /usr/local/apr/lib, again eadable and executable by all.
 From catalina.out I get the following INFO message (this was after I had
tried downloading/compiling APR myself):
INFO: The APR based Apache Tomcat Native library which allows optimal
performance in production environments was not found on the
java.library.path: 
/usr/lib/jvm/java-1.6.0-sun-1.6.0.22.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.22.x86_64/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.22.x86_64/jre/../lib/amd64::/usr/local/apr/lib:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib

Both /usr/lib64 and /usr/local/apr/lib is present, so shouldn't APR
load?
What am I doing wrong? Please bear in mind I'm pretty new to Tomcat, so
I've probably overlooked something basic.

Kind regards

-- 
Tore W. Hermansen
Systemadministrator - Applikasjon - NTNU IT


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message