tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: vhost - servlets not available
Date Thu, 13 Jan 2011 20:01:20 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Johannes,

On 1/13/2011 2:55 PM, Johannes Stein wrote:
> i got it working... i changed the host-entry and set the correct
> CATALINA_HOME and CATALINA_BASE.
> Both were not set correctly.

That'll get you.

> Now i set the following in server.xml:
> 
> for localhost
> appBase="webapps/localhost/"
> 
> for srv2.tudom.de
> appBase="webapps/tudom/"

Though that will work, it may be surprising for a Tomcat admin, who
expects that the "localhost" vhost will point to "webapps" and not a
directory within it. Looking at your filesystem, I would expect webapps
deployed as /localhost and /tudor instead of what's really going on. Of
course, one should always read the server.xml, but it will certainly be
surprising to someone new.

> after that i saw in the localhost directory that i will need a ROOT
> directory in webapps/tudom.

Yes: you should have a ROOT webapp for each of your vhosts unless you
don't care to serve anything at the root (/) level.

> There (webapps/tudom/ROOT/) i deployed my files. Dont know why, but its working.
> Is it regular that i will need a ROOT-directory in my app-base?

Unless you want to deploy to http://srv2.tudom.de/tudom/index.html,
you'll need to have your webapp called ROOT: those are the rules.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk0vWhAACgkQ9CaO5/Lv0PDZvwCgkF4o8sBMbebTbyhoUFFP0mND
ztEAn1zpXz/b6IO6N7SwQoywi08YIwnA
=TgI6
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message