tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: realm authentication no longer works through apache - mod_jk after upgrade still works via straight tomcat 8080
Date Tue, 11 Jan 2011 16:52:29 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Rainer,

On 1/11/2011 6:56 AM, Rainer Jung wrote:
> At the moment there are no open issues about mod_jk and crashes.

...

>> I tried mod_jk-1.2.28-r1 and 1.2.30 and they both give the same result.
> 
> Wonder why you tried 1.2.30 but not the most recent version 1.2.31?

1.2.31 might not be available from their package manager (Gentoo emerge,
looks like).

>> My apache build contains the following modules(minus means not included
>> in build):
> 
> What do you mean by "build contains" and "minus means not included in
> build"? Example: "-substitute" means what? You don't build it and you
> don't use it, or you build it and don't use/load it or you didn't build
> it and use a 3rd-party build?

Gentoo "USE" flags mean optional capabilities. In the USE config below,
"-substitute" means that that USE flag is disabled, and therefore some
corresponding capabilities are not compiled into the binary.

(Gentoo is (usually) source-only, and all packages are compiled on the
local machine, so you gave a great deal of control over the caps for
each package).

http://www.gentoo.org/proj/en/apache/doc/upgrading.xml#use-2.2.6-r4

APACHE2_MODULES are like USE flags, except that they don't pollute the
global registry of USE flags that Gentoo uses.

I didn't see "substitute" anywhere, so that may just be a mistake.

>> www-servers/apache-2.2.16  USE="ssl -debug -doc -ldap (-selinux) -static
>> -suexec -threads" APACHE2_MODULES="actions alias auth_basic authn_alias
>> authn_anon authn_dbm authn_default authn_file authz_dbm authz_default
>> authz_groupfile authz_host authz_owner authz_user autoindex cache cgi
>> cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter
>> file_cache filter headers include info log_config logio mem_cache mime
>> mime_magic negotiation rewrite setenvif speling status unique_id userdir
>> usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta
>> -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy
>> -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http
>> -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork
>> -worker"

Not sure if any of the above could cause a problem: I can't see anything
off the top of my head. Certainly, core dumps will help.

> Which MPM are you actually using?

The APACHE2_MPMS setting indicates that all MPMs listed on the page
above are disabled. Maybe there isn't an MPM at all? That would be
interesting.

David: how about enabling one of the MPMS, re-building, and trying
again? I recommend "prefork" or "worker".

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk0sis0ACgkQ9CaO5/Lv0PCRAgCgqz+vIp4LZGvgS0pUozH729m4
caIAnipJa57cDYnW3BCTbyK9gm7aUf86
=l4vg
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message