tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aggarwal, Ajay" <>
Subject RE: Questions about installing APR
Date Tue, 07 Dec 2010 14:57:19 GMT
One more question. I was thinking of compiling it on a different machine
(call it my build machine) and then copying the necessary files on to
the target machines. These target machines are running the same (linux)
OS as my build machine.

But on my build machine I want to use --prefix=/build/export/mypath and
then copy the necessary files to /usr/lib of the target machines.

I see following files under /build/export/mypath/lib folder of my build
machine. Do I need to copy everything to /usr/lib of target machines?
Including pkgconfig folder?

libtcnative-1.a**  pkgconfig/

The reason I ask is because "pkgconfig/tcnative-1.pc" file contains
paths relative to the prefix I used on my build machine. But this prefix
is not relevant for target machines. What is the pkgconfig folder used


-----Original Message-----
From: Aggarwal, Ajay [] 

Thanks for your help. That worked.

-----Original Message-----
From: Mark Eggers [] 

In RedHat-based Linux distributions (maybe in others), you'll need to
the development packages as well as the base packages.

Look for:


and install.

Then you can do a configure with:

./configure --with-apr=/usr

since the apr-1-config (at least that's what it's called on Fedora 14)
is in 

. . . . just my two cents.


----- Original Message ----
From: "Aggarwal, Ajay" <>

My OS is centos 5.5, which has APR 1.2.7 pre-installed on it.

# rpm -qa | grep apr



I am using Tomcat version 6.0.20 and I located tomcat-native.tar.gz
under tomcat/bin folder. I extracted the contents and now I am in
tomcat/bin/tomcat-native-1.1.16-src/jni/native directory. I have the
"configure" script here.

./configure fails

                Error: configure: error: APR could not be located.
Please use the --with-apr option.

Not sure why I get above error since I have the "apr" RPM installed
(version 1.2.7). I double check for these shared libraries under
/usr/lib and they are all there

ls /usr/lib/libapr*

/usr/lib/  /usr/lib/
/usr/lib/  /usr/lib/

I tried ./configure --with-apr=/usr/lib , but that fails too

Error: checking for APR... configure: error: the --with-apr parameter is
incorrect. It must specify an install prefix, a build directory, or an
apr-config file.

So I downloaded APR version 1.4.2 and compiled and installed it with a
different prefix=/tmp/myapr

Now ./configure --with-apr=/tmp/myapr works fine and I see following
line when I start tomcat

Loaded APR based Apache Tomcat Native library 1.1.16.

APR capabilities: IPv6 [true], sendfile [true], accept filters [false],
random [true].

But I have couple of questions:

1) Is it ok to compile JNI wrapper with APR 1.4.2, but run it with APR
1.2.7 (like I explained above)?

2) Is it ok to use ARP 1.2.7? Or is it strongly recommended to use the
latest version, i.e. APR 1.4.2?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message