tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "K J.Sreekumar" <k.j.sreeku...@comprotechnologies.com>
Subject Re: Tomcat stops responding
Date Sun, 19 Dec 2010 12:03:24 GMT
Hello Andre,

Thank you for your attention to this query.

The these entries in the netstat shows tomcat running. (These were missing
in the original message and were appended in a subsequent mail.)

TCP    0.0.0.0:8009           0.0.0.0:0              LISTENING       5356

  [tomcat6.exe]



  TCP    0.0.0.0:8080           0.0.0.0:0              LISTENING       5356

  [tomcat6.exe]


Yes we are using apache httpd as front-end to tomcat using mod_proxy (not
AJP).
The configuration in httpd.conf are

ProxyPass /rel/ http://localhost:8080/rel/
ProxyPassReverse /rel/ http://localhost:8080/rel/

Please note that to isolate the issue we had replicated this behavior (of
the application) by directly running it on tomcat (port 8080). (reason why
the apache mod_proxy settings were not included in the original mail.)

The server.xml is available as an attachment with the original message.

Could configuration errors be the cause of this problem - that tomcat works
good for a couple of days, and then starts ignoring a few requests, after a
while stops ignoring most of them.

Can a library mismatch trigger such issues ?

Sreekumar


>> Proto  Local Address          Foreign Address        State           PID
>>  TCP    0.0.0.0:21             0.0.0.0:0              LISTENING
>> 1652
>>  [inetinfo.exe]
>>
>>  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
>> 1336
>>  [httpd.exe]
>>
>>
> It looks like the only thing listening to a HTTP port is the above, which
> looks like Apache httpd, not Tomcat.  And I do not see any of the usual
> Tomcat ports there.
> Are you sure that Tomcat really runs on the same host ?
>
> Are you using Apache httpd as a front-end to Tomcat ?
> And if yes, with which connector ?
>
> In your Apache configuration files, do you have any
> - "proxy*" statements ?
> - JkMount .. statements ?
>
> If yes, post them here.
>
> In your Tomcat main configuration file ((tomcat_dir)/conf/server.xml), what
> <Connector ..> tags (uncommented) are there ?  Can you also post them here ?
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message