tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tomcat stops responding
Date Sun, 19 Dec 2010 17:27:35 GMT
2010/12/17 K J.Sreekumar <k.j.sreekumar@comprotechnologies.com>:
> The logs does not show any error.

Do they show anything at all?

> There are only a total of 50-60 threads in the thread dump, mostly in WAIT
> state. Also, it does not show any BLOCKING or LOCKED threads.

It would be interesting to look at the thread dump.

If it is too long for the e-mail, you may post it somewhere else, e.g.
to a pastebin site.

Your telnet test,

> HTTP/1.1 400 Bad Request
> Server: Apache-Coyote/1.1
> Transfer-Encoding: chunked
> Date: Sat, 18 Dec 2010 09:57:04 GMT
> Connection: close

shows that Tomcat processes incoming connections (and correctly
identifies your HTTP/1.1 request as an invalid one). So maybe it is
only your webapp that fails.

> Memory utilization was 400MB only
> TOMCAT restart does not fix the problem. The machine needs to be restarted
> to resume normal operation.

1. Are you sure that restart was successful? I.e., that "stop" part of
it has actually stopped Tomcat and freed resources.

2. Maybe there are some external resources (database? exhausting free
space on a hard drive?)  I wonder what can it be that can be exhausted
and is not freed by Tomcat shutdown. It is easy to exhaust database
connections or open file handles, if you do not close them properly,
but all they should be freed when a Windows application shuts down.

3. Maybe there is anything in the system Events log.

4. If you stop and start Tomcat after the failure, are all the usual
startup time messages present in the logs? Maybe there are some
messages, like the webapp failing to start.

5. You may deploy the manager webapp, accessible as
http://<server>:<port>/manager/html
It will show you the status of your webapps and the requests that are
currently being processed.

> Netstat did not reveal any extraneous connections
>
> We are running Tomcat 6.0.29 on the following platform -
> OS: Windows server 2003 R2 Enterprise Edition SP2
> Hardware: Intel Xeon L5520 2.27 GHz (16 CPU threads )
> The server.xml we are using has been attached with this mail.
>

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message