tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shunhao chen <>
Subject 回复: How to run tomcat 5.5.9 as a service in 64-bit OS?
Date Wed, 01 Dec 2010 10:14:25 GMT
Hi Andre,
    Thanks very much. I will try the x64 bug fix in tomcat 5.5.9 first and I 
will consider seriously about the upgrade.

发件人: André Warnier <>
收件人: Tomcat Users List <>
发送日期: 2010/12/1 (周三) 6:01:16 下午
主 题: Re: How to run tomcat 5.5.9 as a service in 64-bit OS?

Mark Thomas wrote:
> On 01/12/2010 08:40, shunhao chen wrote:
>> Hi all,
>>    I have a web app using tomcat 5.5.9 as app server. All works well in 32-bit

>>OS. But now I have to support this app running on 64-bit OS. So I change the JDK 
>>to use a 64-bit version(jdk1.5.0_22). All works well, but when I run tomcat as a 
>>service, it fails. 
>>    Can anybody help?
> 5.5.9 is very old and has a number of known security vulnerabilities.
> You should consider upgrading.
> The architecture of the service wrapper must match the architecture of
> the JVM so you'll need the 64-bit service wrapper. You can get that from
> the latest commons-daemon download.
More details, and non-official shortcut :
If you must absolutely stay with your current Tomcat 5.5.x, then :
- download the Tomcat 5.5.31 *Core, zip version* of Tomcat 5.5.31 from here
- unzip it to a temporary directory
- in the subdirectory bin/x64, there are 2 files : tomcat5.exe and 
  These are the only 2 files that change for the 64-bit version.
  On your 64-bit system, copy them over the same files in the /bin subdirectory,
  and that's it.

*BUT* as Mark says, it would be much better to start with a current 6.0 version, 
downloadable from here :

Download the *Core, 32/64-bit Windows Installer*
and install it on your 64-bit machine.  The installer will automatically detect 
the type of machine and install the correct version of the above files.
*Then*, when the 64-bit version of Tomcat 6.0 is running, make the changes you 
need to that version, to run your applications.

Do not copy your configuration files from Tomcat 5.5.x to the 6.0.x 
Start from the 6.0.x files, and make the changes in them if needed.

To unsubscribe, e-mail:
For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message