tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Eggers <its_toas...@yahoo.com>
Subject Re: class not found in tomcat's JARs (in $CATALINA_HOME/lib)
Date Tue, 07 Dec 2010 19:29:08 GMT
Out of curiosity, couldn't you use the information in RUNNING.txt under 
"Advanced Configuration - Multiple Tomcat Instances" to meet your requirements?

. . . just a thought.

/mde/

----- Original Message ----
From: frank <frank@cloud.com>


Hi Experts:
    I have read "class not found" in FAQ and "class loader howto" of tomcat6, 
unfortunately, they don't resolve my problem.
    I set CATALINA_BASE and CATALINA_HOME to my directory like:

    CATALINA_BASE=/usr/share/mydir
    CATALINA_HOME=/usr/share/mydir

    then link subdirs (conf/, bin/ ...)of tomcat6 to $CATALINA_HOME, the "lib/" 
points to /usr/share/tomcat6/lib. IMO, tomcat6-servlet-2.5-api.jar, 
tomcat6-jsp-2.1-api-6.0.26.jar, tomcat6-el-2.1-api-6.0.26.jar should be 
automatically be found since they are located at $CATALINA_HOME/lib/. In fact 
this doesn't work, I got errors (see paste at bottom). However, if I added full 
path of these JARs to classpath, things worked. I am puzzled, why common class 
loader doesn't get these files? thank you.


      

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message