tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Ludwig <mil...@gmx.de>
Subject Re: Tomcat stops responding
Date Sat, 18 Dec 2010 14:28:09 GMT
K J.Sreekumar schrieb am 18.12.2010 um 17:57 (+0530):
> (i'm adding my name before my comments so that its easier to identity
> who said what if this conversation builds up further)-

You could configure your mail client to use standard indentation.

> ** Sreekumar.* Using Firefox 3.6x we get the following error
> The connection was reset
> The connection to the server was reset while the page was loading.

> ** Sreekumar.* NETSTAT was output as follows
> 
> Proto  Local Address          Foreign Address        State           PID
>   TCP    0.0.0.0:21             0.0.0.0:0              LISTENING       1652
>   [inetinfo.exe]
> 
>   TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       1336
>   [httpd.exe] […]

There's nothing running on port 8080.

> - do the same from a command window on the server itself, using "localhost"
> as the hostname.  Same result ?
> 
> ***Sreekumar* - The telnet output was as follows (same from local machine
> and a different workstation)
> 
> HTTP/1.1 400 Bad Request
> Server: Apache-Coyote/1.1
> Transfer-Encoding: chunked
> Date: Sat, 18 Dec 2010 09:57:04 GMT
> Connection: close

What hostnames and ports did you use for these two telnet command?

You're getting a Bad Request error because you omitted the Host header.
It should include the hostname, e.g. localhost:

GET / HTTP/1.1
Host: localhost
<CR>
<CR>

> Connection to host lost.
> 
> Next we tried with /HTTP/*1.0 *instead - In this case, when on the local
> machine/server, we did not get any response and the telnet exited
> immediately after the 2nd [ENTER].
> 
> Also, we checked telnet /HTTP/*1.1* after restarting the machine (when
> everything was running fine), it still gives a BAD REQUEST.  But telnet
> requests to /HTTP/*1.0* started working.

HTTP 1.0 doesn't require the Host header. But I don't understand what
worked and what didn't.

-- 
Michael Ludwig

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message