tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Héctor Gómez <pal_puto_mesenger...@hotmail.com>
Subject Problems with new mod_jk and possible misinformation on the website
Date Thu, 18 Nov 2010 12:01:43 GMT

Hi, I'm running a CentOs 5 with Apache 2.0.52. I've tried to connect Apache with Tomcat 7.0.4
using mod_jk
First I tried the jk-1.2.31 version. As I have a i586 I choosed the i386 release, and downloaded
mod_jk-1.2.31-httpd-2.0.x.so  
Ok, here there might be a mistake. On the description you can read "Apache Tomcat Connectors
(mod_jk) 1.2.31 for Linux x86_64". Notice the "x86_64"! (I'm inside the i386 folder!)
That connector is said to be built against version 2.0.52, but it doesn't work. Apache fails
on startup and logs no error, and mod_jk log neither. Maybe the i386 version is not suitable
for a i586, or maybe this is in fact a x86_64 version (as the description says) even if it's
placed into the i386 folder.
Anyway, I downloaded the jk-1.2.30 for i586. That suits my architecture, and Apache starts
up the right way. But... no redirection is done! The connector doesn't seem to be working
as expected. The problem is that this version may not be suitable for me, as it has been build
against version 2.0.61 "and should work with Apache 2.0.55 and later". But mine is 2.0.52
and I can't change it.
Should I downgrade
What can I do? Is there a problem with the jk-1.2.31 for i386? or is it just a misplaced description?
Hope anyone can check that because if so, it would be a severe error.
Thanks in advance for your time
PS: I assume that my worker.properties and mod_jk.conf have good configurations, as I've used
this connector with previos versions of Apache and Tomcat in other systems.
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message