tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard G Curry" <rgcu...@jcpenney.com>
Subject RE: Connector Setting Problem in tomcat 6.0.29
Date Tue, 02 Nov 2010 13:14:37 GMT
The following link points to something similar to what you have here, perhaps it can guide
you to a solution: 

	http://mail-archives.apache.org/mod_mbox/tomcat-users/200705.mbox/%3C4656D0D8.4010107@pidster.com%3E

_______________________________________________________________________________________
«¤»¥«¤»§«¤»¥«¤»§«¤»¥«¤»§«¤»¥«¤»§«¤»¥«¤»§«¤»¥«¤»§«¤»¥«¤»§«¤»¥«¤»§«¤»¥«¤»
_______________________________________________________________________________________
Rick Curry
Common Services -  Software Development
E2 - 066, MS 5210
972-431-9178 (Voice)
972-585-7585 (Pager)
To send a (short) Text Message to my Pager:
9725857585@page.metrocall.com

-----Original Message-----
From: rujin raj [mailto:rujinraj@gmail.com] 
Sent: Tuesday, November 02, 2010 6:51 AM
To: Tomcat Users List
Subject: Connector Setting Problem in tomcat 6.0.29

I am using tomcat 6.0.29 64 bit and java 64 1.6.0 64 bit edition.I configured the http connector
minSpareThreads and MaxSpareThreads. While starting the tomcat it is giving the error as follows.

2 Nov, 2010 4:55:24 PM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.20.
2 Nov, 2010 4:55:24 PM org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters [false], ra ndom [true].
2 Nov, 2010 4:55:24 PM org.apache.catalina.startup.SetAllPropertiesRule
begin
*WARNING: [SetAllPropertiesRule]{Server/Service/Connector} Setting property
'minS*
*pareThreads' to '500' did not find a matching property.*
2 Nov, 2010 4:55:24 PM org.apache.catalina.startup.SetAllPropertiesRule
begin
WARNING: [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'maxS pareThreads'
to '750' did not find a matching property.
2 Nov, 2010 4:55:25 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
2 Nov, 2010 4:55:25 PM org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
2 Nov, 2010 4:55:25 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 880 ms
2 Nov, 2010 4:55:25 PM
org.apache.catalina.mbeans.GlobalResourcesLifecycleListen
er createMBeans
SEVERE: Exception processing Global JNDI Resources
javax.naming.NamingException: Could not load resource factory class [Root except ion is java.lang.ClassNotFoundException:
oracle.jdbc.pool.OracleDataSourceFactor
y]


Herewith i attached my server.xml file.

<!-- A "Connector" represents an endpoint by which requests are received
         and responses are returned. Documentation at :
         Java HTTP Connector: /docs/config/http.html (blocking &
non-blocking)
         Java AJP  Connector: /docs/config/ajp.html
         APR (HTTP/AJP) Connector: /docs/apr.html
         Define a non-SSL HTTP/1.1 Connector on port 8080
    *-->*
*    <Connector port="8080" protocol="HTTP/1.1" *
*               connectionTimeout="20000" *
*               maxThreads="1000" minSpareThreads="500"  *
*               maxSpareThreads="750"*
*               enableLookups="false" disableUploadTimeout="true"*
*               redirectPort="8443" />*
    <!-- A "Connector" using the shared thread pool-->
    <!--
    <Connector executor="tomcatThreadPool"
               port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" />
    -->
    <!-- Define a SSL HTTP/1.1 Connector on port 8443
         This connector uses the JSSE configuration, when using APR, the
         connector should be using the OpenSSL style configuration
         described in the APR documentation -->
    <!--
    <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
   maxThreads="1000" minSpareThreads="500"
               maxSpareThreads="750"
   enableLookups="false" disableUploadTimeout="true"
   scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS" />
    -->

    <!-- Define an AJP 1.3 Connector on port 8009 -->
    <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />


    <!-- An Engine represents the entry point (within Catalina) that processes
         every request.  The Engine implementation for Tomcat stand alone
         analyzes the HTTP headers included with the request, and passes them
         on to the appropriate Host (virtual host).
         Documentation at /docs/config/engine.html -->

Please guide me to resolve this issue.

Regards
Rujinraj
The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential and/or privileged 
material.  If the reader of this message is not the intended recipient,
you are hereby notified that your access is unauthorized, and any review,
dissemination, distribution or copying of this message including any 
attachments is strictly prohibited.  If you are not the intended
recipient, please contact the sender and delete the material from any
computer.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message