tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathaniel Thalluri <nathaniel.thall...@gmail.com>
Subject Tomcat website unreachable on the internet
Date Fri, 26 Nov 2010 18:20:48 GMT
Hi,
 I deployed a public website to Tomcat 7, Windows 2008 server with the
following server.xml.

 <Service name="Catalina">
    <Connector port="8443"
protocol="org.apache.coyote.http11.Http11NioProtocol" SSLEnabled="true"
               maxThreads="200" scheme="https" secure="true" debug="0"
             keystoreFile="keystore" keystorePass="kspwd"
               clientAuth="false" sslProtocol="TLS" address="ipaddress"/>

    <Engine name="Catalina" defaultHost="portal.company.com">

      <Host name="portal.company.com" debug="0" appBase="webapps"

            unpackWARs="true" autoDeploy="true">
        <Context path="/app" docBase="app" reloadable="true"
crossContext="true"/>
        <Alias>portal.company.com</Alias>
        <Valve className="org.apache.catalina.valves.AccessLogValve"
directory="logs"
               prefix="localhost_access_log." suffix=".txt"
               pattern="%h %l %u %t "%r" %s %b" resolveHosts="true"/>
      </Host>

    </Engine>
  </Service>

The website is however unreachable on the internet. When the url is
accessed, a page cannot be displayed error is shown.

The windows hosts file has the following entry:
ipaddress           portal.company.com

 Am I missing something?

Thanks.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message